CVE-2015-1370

NameCVE-2015-1370
DescriptionIncomplete blacklist vulnerability in marked 0.3.2 and earlier for Node.js allows remote attackers to conduct cross-site scripting (XSS) attacks via a vbscript tag in a link.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-marked (PTS)jessie0.3.2+dfsg-1vulnerable
stretch0.3.6+dfsg-1fixed
buster, sid0.3.9+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-markedsource(unstable)0.3.6+dfsg-1unimportant

Notes

https://nodesecurity.io/advisories/marked_vbscript_injection
https://github.com/chjj/marked/issues/492
libv8 is not covered by security support

Search for package or bug name: Reporting problems