CVE-2015-1548

NameCVE-2015-1548
Descriptionmini_httpd 1.21 and earlier allows remote attackers to obtain sensitive information from process memory via an HTTP request with a long protocol string, which triggers an incorrect response size calculation and an out-of-bounds read.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs778925

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mini-httpd (PTS)stretch1.23-1.2fixed
buster1.30-0.2fixed
bullseye, sid1.30-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mini-httpdsource(unstable)1.21-1medium778925

Notes

[squeeze] - mini-httpd <no-dsa> (Minor issue)
[wheezy] - mini-httpd <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems