CVE-2015-1790

NameCVE-2015-1790
DescriptionThe PKCS7_dataDecodefunction in crypto/pkcs7/pk7_doit.c in OpenSSL before 0.9.8zg, 1.0.0 before 1.0.0s, 1.0.1 before 1.0.1n, and 1.0.2 before 1.0.2b allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a PKCS#7 blob that uses ASN.1 encoding and lacks inner EncryptedContent data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-247-1, DSA-3287-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssl (PTS)stretch (security), stretch1.1.0l-1~deb9u1fixed
buster, buster (security)1.1.1d-0+deb10u3fixed
bullseye, sid1.1.1g-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensslsourcesqueeze0.9.8o-4squeeze21DLA-247-1
opensslsourcewheezy1.0.1e-2+deb7u17DSA-3287-1
opensslsourcejessie1.0.1k-3+deb8u1DSA-3287-1
opensslsource(unstable)1.0.2b-1

Notes

http://openssl.org/news/secadv/20150611.txt

Search for package or bug name: Reporting problems