CVE-2015-2313

NameCVE-2015-2313
DescriptionSandstorm Cap'n Proto before 0.4.1.1 and 0.5.x before 0.5.1.2, when an application invokes the totalSize method on an object reader, allows remote peers to cause a denial of service (CPU consumption) via a crafted small message, which triggers a "tight" for loop. NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-2312.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs780568

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
capnproto (PTS)stretch0.5.3-2fixed
buster0.7.0-3fixed
bullseye, sid0.7.0-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
capnprotosource(unstable)0.4.1-3780568

Search for package or bug name: Reporting problems