CVE-2015-2674

NameCVE-2015-2674
DescriptionRestkit allows man-in-the-middle attackers to spoof TLS servers by leveraging use of the ssl.wrap_socket function in Python with the default CERT_NONE value for the cert_reqs argument.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs781813

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-restkit (PTS)wheezy4.1.3-2vulnerable
jessie4.2.2-1vulnerable
sid, stretch4.2.2-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-restkitsource(unstable)(unfixed)medium781813

Notes

[stretch] - python-restkit <ignored> (Minor issue)
[jessie] - python-restkit <ignored> (Minor issue)
[wheezy] - python-restkit <ignored> (Minor issue)
[squeeze] - python-restkit <no-dsa> (Minor issue)
https://github.com/benoitc/restkit/issues/140
http://www.openwall.com/lists/oss-security/2015/03/12/9

Search for package or bug name: Reporting problems