CVE-2015-2754

NameCVE-2015-2754
DescriptionFreeXL before 1.0.0i allows remote attackers to cause a denial of service (stack corruption) and possibly execute arbitrary code via a crafted workbook, related to a "premature EOF."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3208-1
NVD severitymedium (attack range: remote)
Debian Bugs781228

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freexl (PTS)wheezy1.0.0b-1+deb7u3fixed
wheezy (security)1.0.0b-1+deb7u4fixed
jessie1.0.0g-1+deb8u3fixed
jessie (security)1.0.0g-1+deb8u4fixed
stretch (security), stretch1.0.2-2+deb9u1fixed
buster, sid1.0.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freexlsource(unstable)1.0.0g-1+deb8u1medium781228
freexlsourceexperimental1.0.1-1~exp1medium
freexlsourcewheezy1.0.0b-1+deb7u1mediumDSA-3208-1

Notes

Reproducer: https://www.dropbox.com/s/66srfory903w6cl/freexl_d7273f72?dl=0

Search for package or bug name: Reporting problems