CVE-2015-3209

NameCVE-2015-3209
DescriptionHeap-based buffer overflow in the PCNET controller in QEMU allows remote attackers to execute arbitrary code by sending a packet with TXSTATUS_STARTPACKET set and then a crafted packet with TXSTATUS_DEVICEOWNS set.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3284-1, DSA-3285-1, DSA-3286-1
NVD severityhigh
Debian Bugs788460

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)stretch1:2.8+dfsg-6+deb9u9fixed
stretch (security)1:2.8+dfsg-6+deb9u10fixed
buster, buster (security)1:3.1+dfsg-8+deb10u7fixed
bullseye, sid1:5.0-14fixed
xen (PTS)stretch (security), stretch4.8.5.final+shim4.10.4-1+deb9u12fixed
buster, buster (security)4.11.4+24-gddaaccbbab-1~deb10u1fixed
bullseye, sid4.11.4+24-gddaaccbbab-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusourcesqueeze(unfixed)end-of-life
qemusourcewheezy1.1.2+dfsg-6a+deb7u8
qemusourcejessie1:2.1+dfsg-12+deb8u1DSA-3284-1
qemusource(unstable)1:2.3+dfsg-6788460
qemu-kvmsourcesqueeze(unfixed)end-of-life
qemu-kvmsourcewheezy1.1.2+dfsg-6+deb7u8DSA-3285-1
qemu-kvmsource(unstable)(unfixed)
xensourcesqueeze(unfixed)end-of-life
xensourcewheezy4.1.4-3+deb7u8DSA-3286-1
xensourcejessie4.4.1-9+deb8u1DSA-3286-1
xensource(unstable)4.4.0-1
xen-qemu-dm-4.0sourcesqueeze(unfixed)end-of-life

Notes

[squeeze] - xen <end-of-life> (Not supported in Squeeze LTS)
[squeeze] - xen-qemu-dm-4.0 <end-of-life> (Not supported in Squeeze LTS)
[squeeze] - qemu <end-of-life> (Not supported in Squeeze LTS)
[squeeze] - qemu-kvm <end-of-life> (Not supported in Squeeze LTS)
Xen switched to qemu-system in 4.4.0-1
http://xenbits.xen.org/xsa/advisory-135.html

Search for package or bug name: Reporting problems