CVE-2015-3223

NameCVE-2015-3223
DescriptionThe ldb_wildcard_compare function in ldb_match.c in ldb before 1.1.24, as used in the AD LDAP server in Samba 4.x before 4.1.22, 4.2.x before 4.2.7, and 4.3.x before 4.3.3, mishandles certain zero values, which allows remote attackers to cause a denial of service (infinite loop) via crafted packets.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3433-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ldb (PTS)stretch (security), stretch2:1.1.27-1+deb9u1fixed
buster2:1.5.1+really1.4.6-3fixed
bullseye, sid2:2.1.4-2fixed
samba (PTS)stretch (security), stretch2:4.5.16+dfsg-1+deb9u2fixed
buster2:4.9.5+dfsg-5fixed
buster (security)2:4.9.5+dfsg-5+deb10u1fixed
bullseye, sid2:4.12.5+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ldbsourcejessie2:1.1.17-2+deb8u1
ldbsource(unstable)2:1.1.24-1
sambasourcesqueeze(not affected)
sambasourcewheezy2:3.6.6-6+deb7u6DSA-3433-1
sambasourcejessie2:4.1.17+dfsg-2+deb8u1DSA-3433-1
sambasource(unstable)2:4.1.22+dfsg-1

Notes

[wheezy] - samba <not-affected> (Only affects 4.0.0 to 4.3.2)
[squeeze] - samba <not-affected> (Only affects 4.0.0 to 4.3.2)
[wheezy] - ldb <no-dsa> (Minor issue, only relevant in conjunction with Samba 4, which isn't in wheezy)
[squeeze] - ldb <no-dsa> (Minor issue)
https://www.samba.org/samba/security/CVE-2015-3223.html
https://git.samba.org/?p=samba.git;a=commit;h=fb456954f332c07a645226d59b3b00ec252f8b26 (v4-1-stable)
https://git.samba.org/?p=samba.git;a=commit;h=bb1b783ee9d7259cfc6a1fe882f22189747f8684 (v4-1-stable)
Samba update needs as well fixed ldb

Search for package or bug name: Reporting problems