CVE-2015-3245

NameCVE-2015-3245
DescriptionIncomplete blacklist vulnerability in the chfn function in libuser before 0.56.13-8 and 0.60 before 0.60-7, as used in the userhelper program in the usermode package, allows local users to cause a denial of service (/etc/passwd corruption) via a newline character in the GECOS field.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-468-1
NVD severitylow
Debian Bugs793465

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libuser (PTS)buster, stretch1:0.62~dfsg-0.1fixed
bullseye, sid1:0.62~dfsg-0.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libusersource(unstable)1:0.62~dfsg-0.1793465
libusersourcewheezy1:0.56.9.dfsg.1-1.2+deb7u1DLA-468-1

Notes

[jessie] - libuser <no-dsa> (Minor issue)
initially attributed to usermode package, root-cause fixed in libuser instead

Search for package or bug name: Reporting problems