CVE-2015-3246

NameCVE-2015-3246
Descriptionlibuser before 0.56.13-8 and 0.60 before 0.60-7, as used in the userhelper program in the usermode package, directly modifies /etc/passwd, which allows local users to cause a denial of service (inconsistent file state) by causing an error during the modification. NOTE: this issue can be combined with CVE-2015-3245 to gain privileges.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-468-1
NVD severityhigh (attack range: local)
Debian Bugs793465

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libuser (PTS)jessie1:0.60~dfsg-1.2vulnerable
bullseye, sid, buster, stretch1:0.62~dfsg-0.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libusersource(unstable)1:0.62~dfsg-0.1high793465
libusersourcewheezy1:0.56.9.dfsg.1-1.2+deb7u1highDLA-468-1

Notes

[jessie] - libuser <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems