Descriptionlibinfinity before 0.6.6-1 does not validate expired SSL certificates, which allows remote attackers to have unspecified impact via unknown vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs783601

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libinfinity (PTS)buster0.7.1-1fixed
bookworm, bullseye, sid0.7.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libinfinitysourcesqueeze(not affected)
libinfinitysourcewheezy(not affected)


[wheezy] - libinfinity <not-affected> (vulnerable code not present)
[squeeze] - libinfinity <not-affected> (vulnerable code not present)

Search for package or bug name: Reporting problems