CVE-2015-3900

NameCVE-2015-3900
DescriptionRubyGems 2.0.x before 2.0.16, 2.2.x before 2.2.4, and 2.4.x before 2.4.7 does not validate the hostname when fetching gems or making API requests, which allows remote attackers to redirect requests to arbitrary domains via a crafted DNS SRV record, aka a "DNS hijack attack."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs790111, 790119

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jruby (PTS)jessie1.5.6-9fixed
jessie (security)1.5.6-9+deb8u1fixed
stretch (security), stretch1.7.26-1+deb9u1fixed
bullseye, sid, buster9.1.17.0-3fixed
ruby2.1 (PTS)jessie2.1.5-2+deb8u3fixed
jessie (security)2.1.5-2+deb8u7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jrubysource(unstable)1.7.20.1-2
jrubysourcejessie(not affected)
jrubysourcesqueeze(not affected)
jrubysourcewheezy(not affected)
libgems-rubysource(unstable)(not affected)
ruby1.8source(unstable)(not affected)
ruby1.9.1source(unstable)(not affected)
ruby2.1source(unstable)2.1.5-4790119
ruby2.1sourcejessie2.1.5-2+deb8u2
ruby2.2source(unstable)2.2.2-3790111
rubygemssource(unstable)(not affected)

Notes

- rubygems <not-affected> (Affects versions between 2.0 and 2.4.6)
- libgems-ruby <not-affected> (Affects versions between 2.0 and 2.4.6)
- ruby1.8 <not-affected> (Vulnerable code not present)
- ruby1.9.1 <not-affected> (Bundles 1.8.23, vulnerable code introduced in later 1.9.1 versions)
[jessie] - jruby <not-affected> (Vulnerable code introduced with 1.7.19)
[wheezy] - jruby <not-affected> (Vulnerable code introduced with 1.7.19)
[squeeze] - jruby <not-affected> (Vulnerable code introduced with 1.7.19)
https://github.com/rubygems/rubygems/commit/6bbee35
https://github.com/rubygems/rubygems/commit/5c7bfb5
http://blog.rubygems.org/2015/05/14/CVE-2015-3900.html

Search for package or bug name: Reporting problems