Information on source package jruby

Available versions

ReleaseVersion
stretch1.7.26-1+deb9u1
stretch (security)1.7.26-1+deb9u3
buster9.1.17.0-3
sid9.1.17.0-3

Open issues

BugstretchbustersidDescription
CVE-2021-32066vulnerable (no DSA)vulnerable (no DSA)vulnerableAn issue was discovered in Ruby through 2.6.7, 2.7.x through 2.7.3, an ...
CVE-2021-31810vulnerable (no DSA)vulnerable (no DSA)vulnerableAn issue was discovered in Ruby through 2.6.7, 2.7.x through 2.7.3, an ...
CVE-2020-25613fixedvulnerable (no DSA)vulnerableAn issue was discovered in Ruby through 2.5.8, 2.6.x through 2.6.6, an ...
CVE-2019-16255fixedvulnerable (no DSA)vulnerableRuby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allow ...
CVE-2019-16254fixedvulnerable (no DSA)vulnerableRuby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allow ...
CVE-2019-16201fixedvulnerable (no DSA)vulnerableWEBrick::HTTPAuth::DigestAuth in Ruby through 2.4.7, 2.5.x through 2.5 ...
CVE-2017-17742fixedvulnerable (no DSA)vulnerableRuby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x befo ...

Resolved issues

BugDescription
CVE-2019-15845Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 misha ...
CVE-2019-8325An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since ...
CVE-2019-8324An issue was discovered in RubyGems 2.6 and later through 3.0.2. A cra ...
CVE-2019-8323An issue was discovered in RubyGems 2.6 and later through 3.0.2. Gem:: ...
CVE-2019-8322An issue was discovered in RubyGems 2.6 and later through 3.0.2. The g ...
CVE-2019-8321An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since ...
CVE-2019-8320A Directory Traversal issue was discovered in RubyGems 2.7.6 and later ...
CVE-2018-1000079RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: ...
CVE-2018-1000078RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: ...
CVE-2018-1000077RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: ...
CVE-2018-1000076RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: ...
CVE-2018-1000075RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: ...
CVE-2018-1000074RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: ...
CVE-2018-1000073RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: ...
CVE-2015-4020RubyGems 2.0.x before 2.0.17, 2.2.x before 2.2.5, and 2.4.x before 2.4 ...
CVE-2015-3900RubyGems 2.0.x before 2.0.16, 2.2.x before 2.2.4, and 2.4.x before 2.4 ...
CVE-2012-5370JRuby computes hash values without properly restricting the ability to ...
CVE-2011-4838JRuby before 1.6.5.1 computes hash values without restricting the abil ...
CVE-2010-1330The regular expression engine in JRuby before 1.4.1, when $KCODE is se ...

Security announcements

DSA / DLADescription
DLA-2392-1jruby - security update
DLA-2330-1jruby - security update
DLA-2027-1jruby - security update
DLA-1796-1jruby - security update
DSA-4219-1jruby - security update
DLA-1352-1jruby - security update
DLA-1337-1jruby - security update
DLA-209-1jruby - security update

Search for package or bug name: Reporting problems