CVE-2015-4035

NameCVE-2015-4035
Descriptionscripts/xzgrep.in in xzgrep 5.2.x before 5.2.0, before 5.0.0 does not properly process file names containing semicolons, which allows remote attackers to execute arbitrary code by having a user run xzgrep on a crafted file name.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xz-utils (PTS)buster, buster (security)5.2.4-1+deb10u1fixed
bullseye (security), bullseye5.2.5-2.1~deb11u1fixed
bookworm5.4.1-0.2fixed
sid, trixie5.6.1+really5.4.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xz-utilssource(unstable)(not affected)

Notes

- xz-utils <not-affected> (Affects 4.999.9beta)
https://www.openwall.com/lists/oss-security/2015/05/18/7

Search for package or bug name: Reporting problems