CVE-2015-4103

NameCVE-2015-4103
DescriptionXen 3.3.x through 4.5.x does not properly restrict write access to the host MSI message data field, which allows local x86 HVM guest administrators to cause a denial of service (host interrupt handling confusion) via vectors related to qemu and accessing spanning multiple fields.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3284-1, DSA-3286-1
NVD severitymedium (attack range: local)
Debian Bugs787547

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie1:2.1+dfsg-12+deb8u6fixed
jessie (security)1:2.1+dfsg-12+deb8u7fixed
stretch (security), stretch1:2.8+dfsg-6+deb9u4fixed
buster, sid1:2.12+dfsg-3fixed
xen (PTS)jessie4.4.1-9+deb8u10fixed
jessie (security)4.4.4lts2-0+deb8u1fixed
buster, stretch4.8.3+xsa267+shim4.10.1+xsa267-1+deb9u9fixed
stretch (security)4.8.4+xsa273+shim4.10.1+xsa273-1+deb9u10fixed
sid4.11.1~pre.20180911.5acdd26fdc+dfsg-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1:2.3+dfsg-5medium787547
qemusourcejessie1:2.1+dfsg-12+deb8u1mediumDSA-3284-1
qemusourcesqueeze(not affected)
qemusourcewheezy(not affected)
qemu-kvmsource(unstable)(not affected)
xensource(unstable)4.4.0-1medium
xensourcejessie4.4.1-9+deb8u1mediumDSA-3286-1
xensourcesqueeze(unfixed)end-of-life
xensourcewheezy4.1.4-3+deb7u8mediumDSA-3286-1

Notes

[wheezy] - qemu <not-affected> (Vulnerable code not present)
[squeeze] - qemu <not-affected> (Vulnerable code not present)
- qemu-kvm <not-affected> (Vulnerable code not present)
[squeeze] - xen <end-of-life> (Not supported in Squeeze LTS)
Xen switched to qemu-system in 4.4.0-1
http://xenbits.xen.org/xsa/advisory-128.html

Search for package or bug name: Reporting problems