CVE-2015-4104

NameCVE-2015-4104
DescriptionXen 3.3.x through 4.5.x does not properly restrict access to PCI MSI mask bits, which allows local x86 HVM guest users to cause a denial of service (unexpected interrupt and host crash) via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3284-1, DSA-3286-1
NVD severityhigh (attack range: remote)
Debian Bugs787547

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)wheezy1.1.2+dfsg-6a+deb7u12fixed
wheezy (security)1.1.2+dfsg-6+deb7u23fixed
jessie (security), jessie1:2.1+dfsg-12+deb8u6fixed
stretch1:2.8+dfsg-6fixed
stretch (security)1:2.8+dfsg-6+deb9u2fixed
buster1:2.8+dfsg-7fixed
sid1:2.10.0+dfsg-1fixed
qemu-kvm (PTS)wheezy1.1.2+dfsg-6+deb7u12fixed
wheezy (security)1.1.2+dfsg-6+deb7u23fixed
xen (PTS)wheezy4.1.4-3+deb7u9fixed
wheezy (security)4.1.6.lts1-8fixed
jessie4.4.1-9+deb8u9fixed
jessie (security)4.4.1-9+deb8u10fixed
buster, sid, stretch4.8.1-1+deb9u1fixed
stretch (security)4.8.1-1+deb9u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1:2.3+dfsg-5high787547
qemusourcejessie1:2.1+dfsg-12+deb8u1highDSA-3284-1
qemusourcesqueeze(not affected)
qemusourcewheezy(not affected)
qemu-kvmsource(unstable)(not affected)
xensource(unstable)4.4.0-1high
xensourcejessie4.4.1-9+deb8u1highDSA-3286-1
xensourcesqueeze(unfixed)end-of-life
xensourcewheezy4.1.4-3+deb7u8highDSA-3286-1

Notes

[wheezy] - qemu <not-affected> (Vulnerable code not present)
[squeeze] - qemu <not-affected> (Vulnerable code not present)
- qemu-kvm <not-affected> (Vulnerable code not present)
[squeeze] - xen <end-of-life> (Not supported in Squeeze LTS)
Xen switched to qemu-system in 4.4.0-1
http://xenbits.xen.org/xsa/advisory-129.html

Search for package or bug name: Reporting problems