CVE-2015-4105

NameCVE-2015-4105
DescriptionXen 3.3.x through 4.5.x enables logging for PCI MSI-X pass-through error messages, which allows local x86 HVM guests to cause a denial of service (host disk consumption) via certain invalid operations.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-3284-1, DSA-3286-1
Debian Bugs787547

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)buster1:3.1+dfsg-8+deb10u8fixed
buster (security)1:3.1+dfsg-8+deb10u9fixed
bullseye, bullseye (security)1:5.2+dfsg-11+deb11u2fixed
bookworm, sid1:7.1+dfsg-2fixed
xen (PTS)buster, buster (security)4.11.4+107-gef32c7afa2-1fixed
bullseye4.14.5+24-g87d90d511c-1fixed
bullseye (security)4.14.5+86-g1c354767d5-1fixed
bookworm, sid4.16.2+90-g0d39a6d1ae-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusourcesqueeze(not affected)
qemusourcewheezy(not affected)
qemusourcejessie1:2.1+dfsg-12+deb8u1DSA-3284-1
qemusource(unstable)1:2.3+dfsg-5787547
qemu-kvmsource(unstable)(not affected)
xensourcesqueeze(unfixed)end-of-life
xensourcewheezy4.1.4-3+deb7u8DSA-3286-1
xensourcejessie4.4.1-9+deb8u1DSA-3286-1
xensource(unstable)4.4.0-1

Notes

[wheezy] - qemu <not-affected> (Vulnerable code not present)
[squeeze] - qemu <not-affected> (Vulnerable code not present)
- qemu-kvm <not-affected> (Vulnerable code not present)
[squeeze] - xen <end-of-life> (Not supported in Squeeze LTS)
Xen switched to qemu-system in 4.4.0-1
http://xenbits.xen.org/xsa/advisory-130.html

Search for package or bug name: Reporting problems