CVE-2015-4141

NameCVE-2015-4141
DescriptionThe WPS UPnP function in hostapd, when using WPS AP, and wpa_supplicant, when using WPS external registrar (ER), 0.7.0 through 2.4 allows remote attackers to cause a denial of service (crash) via a negative chunk length, which triggers an out-of-bounds read or heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3397-1
NVD severitymedium (attack range: remote)
Debian Bugs787372

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wpa (PTS)wheezy1.0-3+deb7u3fixed
wheezy (security)1.0-3+deb7u4fixed
jessie2.3-1+deb8u4fixed
jessie (security)2.3-1+deb8u5fixed
stretch2:2.4-1fixed
stretch (security)2:2.4-1+deb9u1fixed
buster, sid2:2.4-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hostapdsource(unstable)(unfixed)medium
hostapdsourcesqueeze(not affected)
wpasource(unstable)2.3-2.2medium787372
wpasourcejessie2.3-1+deb8u3mediumDSA-3397-1
wpasourcewheezy1.0-3+deb7u3mediumDSA-3397-1
wpasupplicantsource(unstable)(unfixed)unimportant
wpasupplicantsourcesqueeze(not affected)

Notes

[squeeze] - wpasupplicant <not-affected> (Affects v0.7.0-v2.4 with CONFIG_WPS_ER=y in the build configuration)
[squeeze] - hostapd <not-affected> (Affects 0.7.0-v2.4 with CONFIG_WPS_UPNP=y in the build configuration and upnp_iface parameter on runtime)
http://w1.fi/security/2015-2/
http://w1.fi/security/2015-2/wps-upnp-http-chunked-transfer-encoding.txt
http://www.openwall.com/lists/oss-security/2015/05/09/4

Search for package or bug name: Reporting problems