CVE-2015-4142

NameCVE-2015-4142
DescriptionInteger underflow in the WMM Action frame parser in hostapd 0.5.5 through 2.4 and wpa_supplicant 0.7.0 through 2.4, when used for AP mode MLME/SME functionality, allows remote attackers to cause a denial of service (crash) via a crafted frame, which triggers an out-of-bounds read.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-260-1, DSA-3397-1
NVD severitymedium (attack range: remote)
Debian Bugs787373

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wpa (PTS)wheezy1.0-3+deb7u3fixed
wheezy (security)1.0-3+deb7u4fixed
jessie2.3-1+deb8u4fixed
jessie (security)2.3-1+deb8u5fixed
stretch2:2.4-1fixed
stretch (security)2:2.4-1+deb9u1fixed
buster, sid2:2.4-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hostapdsource(unstable)(unfixed)medium
hostapdsourcesqueeze1:0.6.10-2+squeeze2mediumDLA-260-1
wpasource(unstable)2.3-2.2medium787373
wpasourcejessie2.3-1+deb8u3mediumDSA-3397-1
wpasourcewheezy1.0-3+deb7u3mediumDSA-3397-1
wpasupplicantsource(unstable)(unfixed)medium
wpasupplicantsourcesqueeze(not affected)

Notes

[squeeze] - wpasupplicant <not-affected> (0.7.0-v2.4 with with specific configurations)
http://w1.fi/security/2015-3/
http://w1.fi/security/2015-3/integer-underflow-in-ap-mode-wmm-action-frame.txt
http://www.openwall.com/lists/oss-security/2015/05/09/5

Search for package or bug name: Reporting problems