CVE-2015-4146

NameCVE-2015-4146
DescriptionThe EAP-pwd peer implementation in hostapd and wpa_supplicant 1.0 through 2.4 does not clear the L (Length) and M (More) flags before determining if a response should be fragmented, which allows remote attackers to cause a denial of service (crash) via a crafted message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3397-1
NVD severitymedium (attack range: remote)
Debian Bugs787371

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wpa (PTS)wheezy1.0-3+deb7u3fixed
wheezy (security)1.0-3+deb7u5fixed
jessie (security), jessie2.3-1+deb8u5fixed
stretch (security), stretch2:2.4-1+deb9u1fixed
buster2:2.4-1.1fixed
sid2:2.6-13fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hostapdsource(unstable)(not affected)
wpasource(unstable)2.3-2.2medium787371
wpasourcejessie2.3-1+deb8u3mediumDSA-3397-1
wpasourcewheezy1.0-3+deb7u3mediumDSA-3397-1
wpasupplicantsource(unstable)(not affected)

Notes

[wheezy] - wpa <not-affected> (Vulnerable code introduced later)
support for fragmentation added in https://w1.fi/cgit/hostap/commit/?id=5ea93947ca67ba83529798b806a15b247cdb2e93
- wpasupplicant <not-affected> (v1.0-v2.4 with CONFIG_EAP_PWD=y)
- hostapd <not-affected> (v1.0-v2.4 with CONFIG_EAP_PWD=y)
http://w1.fi/security/2015-4/
http://w1.fi/security/2015-4/eap-pwd-missing-payload-length-validation.txt
http://w1.fi/security/2015-4/0005-EAP-pwd-peer-Fix-asymmetric-fragmentation-behavior.patch
http://www.openwall.com/lists/oss-security/2015/05/07/5

Search for package or bug name: Reporting problems