CVE-2015-4163

NameCVE-2015-4163
DescriptionGNTTABOP_swap_grant_ref in Xen 4.2 through 4.5 does not check the grant table operation version, which allows local guest domains to cause a denial of service (NULL pointer dereference) via a hypercall without a GNTTABOP_setup_table or GNTTABOP_set_version.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3286-1
NVD severitymedium (attack range: local)
Debian Bugs795721

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)wheezy4.1.4-3+deb7u9fixed
wheezy (security)4.1.6.lts1-10fixed
jessie4.4.1-9+deb8u9fixed
jessie (security)4.4.1-9+deb8u10fixed
buster, sid, stretch (security), stretch4.8.1-1+deb9u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.6.0-1medium795721
xensourcejessie4.4.1-9+deb8u1mediumDSA-3286-1
xensourcesqueeze(not affected)
xensourcewheezy4.1.4-3+deb7u8mediumDSA-3286-1

Notes

[wheezy] - xen <not-affected> (Xen 4.2 onwards are vulnerable)
[squeeze] - xen <not-affected> (Xen 4.2 onwards are vulnerable)
http://xenbits.xen.org/xsa/advisory-134.html

Search for package or bug name: Reporting problems