CVE-2015-4164

NameCVE-2015-4164
DescriptionThe compat_iret function in Xen 3.1 through 4.5 iterates the wrong way through a loop, which allows local 32-bit PV guest administrators to cause a denial of service (large loop and system hang) via a hypercall_iret call with EFLAGS.VM set.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3286-1
NVD severitymedium
Debian Bugs795721

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)stretch (security), stretch4.8.5.final+shim4.10.4-1+deb9u12fixed
buster4.11.4+37-g3263f257ca-1fixed
buster (security)4.11.4+57-g41a822c392-2fixed
bullseye, sid4.14.0+88-g1d1d1f5391-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensourcesqueeze(unfixed)end-of-life
xensourcewheezy4.1.4-3+deb7u8DSA-3286-1
xensourcejessie4.4.1-9+deb8u1DSA-3286-1
xensource(unstable)4.6.0-1795721

Notes

[squeeze] - xen <end-of-life> (Not supported in Squeeze LTS)
http://xenbits.xen.org/xsa/advisory-136.html

Search for package or bug name: Reporting problems