CVE-2015-5190

NameCVE-2015-5190
DescriptionThe pcsd web UI in PCS 0.9.139 and earlier allows remote authenticated users to execute arbitrary commands via "escape characters" in a URL.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pcs (PTS)stretch (security), stretch0.9.155+dfsg-2+deb9u1fixed
buster0.10.1-2fixed
bullseye, sid0.10.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pcssource(unstable)(not affected)

Notes

- pcs <not-affected> (Fixed before initial release to Debian)
https://github.com/feist/pcs/commit/634f6d93e4091946441f366e29859ed64a2c977a (0.9.144)

Search for package or bug name: Reporting problems