CVE-2015-5312

NameCVE-2015-5312
DescriptionThe xmlStringLenDecodeEntities function in parser.c in libxml2 before 2.9.3 does not properly prevent entity expansion, which allows context-dependent attackers to cause a denial of service (CPU consumption) via crafted XML data, a different vulnerability than CVE-2014-3660.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-373-1, DSA-3430-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxml2 (PTS)wheezy2.8.0+dfsg1-7+wheezy5fixed
wheezy (security)2.8.0+dfsg1-7+wheezy11fixed
jessie (security), jessie2.9.1+dfsg1-5+deb8u5fixed
stretch (security), stretch2.9.4+dfsg1-2.2+deb9u1fixed
buster2.9.4+dfsg1-5.1fixed
sid2.9.4+dfsg1-5.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxml2source(unstable)2.9.3+dfsg1-1high
libxml2sourcejessie2.9.1+dfsg1-5+deb8u1highDSA-3430-1
libxml2sourcesqueeze2.7.8.dfsg-2+squeeze16highDLA-373-1
libxml2sourcewheezy2.8.0+dfsg1-7+wheezy5highDSA-3430-1

Notes

https://git.gnome.org/browse/libxml2/commit/?id=69030714cde66d525a8884bda01b9e8f0abf8e1e (v2.9.3)
https://bugzilla.gnome.org/show_bug.cgi?id=756733 (upstream bug not yet open)

Search for package or bug name: Reporting problems