CVE-2015-5315

NameCVE-2015-5315
DescriptionThe eap_pwd_process function in eap_peer/eap_pwd.c in wpa_supplicant 2.x before 2.6 does not validate that the reassembly buffer is large enough for the final fragment when EAP-pwd is enabled in a network configuration profile, which allows remote attackers to cause a denial of service (process termination) via a large final fragment in an EAP-pwd message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3397-1
NVD severitymedium (attack range: remote)
Debian Bugs804708

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wpa (PTS)jessie, jessie (security)2.3-1+deb8u5fixed
stretch, stretch (security)2:2.4-1+deb9u1fixed
buster, sid2:2.6-17fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hostapdsource(unstable)(not affected)
wpasource(unstable)2.3-2.3medium804708
wpasourcejessie2.3-1+deb8u3mediumDSA-3397-1
wpasourcewheezy1.0-3+deb7u3mediumDSA-3397-1
wpasupplicantsource(unstable)(not affected)

Notes

[wheezy] - wpa <not-affected> (v2.0-v2.5 with CONFIG_EAP_PWD=y)
- wpasupplicant <not-affected> (v2.0-v2.5 with CONFIG_EAP_PWD=y)
- hostapd <not-affected> (v2.0-v2.5 with CONFIG_EAP_PWD=y)
http://w1.fi/security/2015-7/
https://w1.fi/security/2015-7/eap-pwd-missing-last-fragment-length-validation.txt
https://w1.fi/security/2015-7/0001-EAP-pwd-peer-Fix-last-fragment-length-validation.patch

Search for package or bug name: Reporting problems