CVE-2015-5316

NameCVE-2015-5316
DescriptionThe eap_pwd_perform_confirm_exchange function in eap_peer/eap_pwd.c in wpa_supplicant 2.x before 2.6, when EAP-pwd is enabled in a network configuration profile, allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via an EAP-pwd Confirm message followed by the Identity exchange.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3397-1
NVD severitymedium (attack range: remote)
Debian Bugs804710

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wpa (PTS)jessie (security), jessie2.3-1+deb8u5fixed
stretch (security), stretch2:2.4-1+deb9u1fixed
buster, sid2:2.6-17fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hostapdsource(unstable)(not affected)
wpasource(unstable)2.3-2.3medium804710
wpasourcejessie2.3-1+deb8u3mediumDSA-3397-1
wpasourcewheezy1.0-3+deb7u3mediumDSA-3397-1
wpasupplicantsource(unstable)(not affected)

Notes

[wheezy] - wpa <not-affected> (v2.3-v2.5 with CONFIG_EAP_PWD=y)
- wpasupplicant <not-affected> (v2.3-v2.5 with CONFIG_EAP_PWD=y)
- hostapd <not-affected> (v2.3-v2.5 with CONFIG_EAP_PWD=y)
http://w1.fi/security/2015-8/
https://w1.fi/security/2015-8/eap-pwd-unexpected-confirm.txt
https://w1.fi/security/2015-8/0001-EAP-pwd-peer-Fix-error-path-for-unexpected-Confirm-m.patch

Search for package or bug name: Reporting problems