CVE-2015-5963

NameCVE-2015-5963
Descriptioncontrib.sessions.middleware.SessionMiddleware in Django 1.8.x before 1.8.4, 1.7.x before 1.7.10, 1.4.x before 1.4.22, and possibly other versions allows remote attackers to cause a denial of service (session store consumption or session record removal) via a large number of requests to contrib.auth.views.logout, which triggers the creation of an empty session record.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-301-1, DSA-3338-1
NVD severitymedium (attack range: remote)
Debian Bugs796104

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-django (PTS)wheezy1.4.5-1+deb7u16fixed
wheezy (security)1.4.22-1+deb7u3fixed
jessie (security), jessie1.7.11-1+deb8u2fixed
stretch1:1.10.7-2fixed
buster, sid1:1.11.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-djangosource(unstable)1.7.10-1medium796104
python-djangosourcejessie1.7.7-1+deb8u2mediumDSA-3338-1
python-djangosourcesqueeze1.2.3-3+squeeze14mediumDLA-301-1
python-djangosourcewheezy1.4.5-1+deb7u13mediumDSA-3338-1

Notes

https://www.djangoproject.com/weblog/2015/aug/18/security-releases/

Search for package or bug name: Reporting problems