CVE-2015-6506

NameCVE-2015-6506
DescriptionCross-site scripting (XSS) vulnerability in the cryptography interface in Request Tracker (RT) before 4.2.12 allows remote attackers to inject arbitrary web script or HTML via a crafted public key.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3335-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
request-tracker4 (PTS)wheezy4.0.7-5+deb7u4fixed
wheezy (security)4.0.7-5+deb7u5fixed
jessie4.2.8-3+deb8u3fixed
jessie (security)4.2.8-3+deb8u2fixed
stretch4.4.1-3+deb9u3fixed
stretch (security)4.4.1-3+deb9u1fixed
buster, sid4.4.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
request-tracker4source(unstable)4.2.11-2medium
request-tracker4sourcejessie4.2.8-3+deb8u1medium
request-tracker4sourcewheezy4.0.7-5+deb7u4mediumDSA-3335-1

Notes

[wheezy] - request-tracker4 <not-affected> (Vulnerable code not present)
https://github.com/bestpractical/rt/commit/36a461947b00b105336adb4997d1c7767d8484c4
http://www.openwall.com/lists/oss-security/2015/08/13/8

Search for package or bug name: Reporting problems