CVE-2015-6673

NameCVE-2015-6673
DescriptionUse-after-free vulnerability in Decoder.cpp in libpgf before 6.15.32.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs798032

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpgf (PTS)jessie6.14.12-3vulnerable
bullseye, sid, buster, stretch6.14.12-3.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpgfsource(unstable)6.14.12-3.2high798032

Notes

[jessie] - libpgf <no-dsa> (Minor issue, can be fixed via a point release)
http://www.openwall.com/lists/oss-security/2015/08/19/14
Details on the CVE assignment: http://www.openwall.com/lists/oss-security/2015/08/25/9
https://sourceforge.net/p/libpgf/code/147/
https://sourceforge.net/p/libpgf/code/148/

Search for package or bug name: Reporting problems