CVE-2015-6674

NameCVE-2015-6674
DescriptionBuffer underflow vulnerability in the Debian inspircd package before 2.0.5-1+deb7u1 for wheezy and before 2.0.16-1 for jessie and sid. NOTE: This issue exists as an additional issue from an incomplete fix of CVE-2012-1836.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-276-1, DSA-3226-1
NVD severityhigh (attack range: remote)
Debian Bugs780880

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
inspircd (PTS)wheezy, wheezy (security)2.0.5-1+deb7u2fixed
jessie (security), jessie2.0.17-1+deb8u2fixed
stretch2.0.23-2fixed
buster, sid2.0.24-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
inspircdsource(unstable)2.0.16-1high780880
inspircdsourcesqueeze1.1.22+dfsg-4+squeeze2highDLA-276-1
inspircdsourcewheezy2.0.5-1+deb7u1highDSA-3226-1

Notes

Correct fix: https://github.com/inspircd/inspircd/commit/ed28c1ba666b39581adb860bf51cdde43c84cc89
http://www.openwall.com/lists/oss-security/2015/03/29/5

Search for package or bug name: Reporting problems