CVE-2015-6764

NameCVE-2015-6764
DescriptionThe BasicJsonStringifier::SerializeJSArray function in json-stringifier.h in the JSON stringifier in Google V8, as used in Google Chrome before 47.0.2526.73, improperly loads array elements, which allows remote attackers to cause a denial of service (out-of-bounds memory access) or possibly have unspecified other impact via crafted JavaScript code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3415-1
NVD severityhigh (attack range: remote)
Debian Bugs806385

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)wheezy, wheezy (security)37.0.2062.120-1~deb7u1vulnerable
jessie (security), jessie57.0.2987.98-1~deb8u1fixed
stretch (security), stretch61.0.3163.100-1~deb9u1fixed
buster, sid61.0.3163.100-2fixed
libv8-3.14 (PTS)jessie3.14.5.8-8.1vulnerable
stretch, sid3.14.5.8-11vulnerable
nodejs (PTS)jessie0.10.29~dfsg-2fixed
stretch4.8.2~dfsg-1fixed
buster4.8.4~dfsg-1fixed
sid6.11.4~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersource(unstable)47.0.2526.73-1high
chromium-browsersourcejessie47.0.2526.73-1~deb8u1highDSA-3415-1
chromium-browsersourcesqueeze(unfixed)end-of-life
chromium-browsersourcewheezy(unfixed)end-of-life
libv8-3.14source(unstable)(unfixed)unimportant
nodejssource(unstable)4.2.3~dfsg-1high806385
nodejssourcejessie(not affected)

Notes

libv8 not covered by security support
[jessie] - nodejs <not-affected> (0.10 series not affected)
https://nodejs.org/en/blog/vulnerability/cve-2015-8027_cve-2015-6764/

Search for package or bug name: Reporting problems