CVE-2015-6806

NameCVE-2015-6806
DescriptionThe MScrollV function in ansi.c in GNU screen 4.3.1 and earlier does not properly limit recursion, which allows remote attackers to cause a denial of service (stack consumption) via an escape sequence with a large repeat count value.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-305-1, DSA-3352-1
NVD severitymedium (attack range: remote)
Debian Bugs797624

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
screen (PTS)wheezy, wheezy (security)4.1.0~20120320gitdb59704-7+deb7u1fixed
jessie (security), jessie4.2.1-3+deb8u1fixed
stretch4.5.0-6fixed
buster, sid4.6.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
screensource(unstable)4.3.1-2medium797624
screensourcejessie4.2.1-3+deb8u1mediumDSA-3352-1
screensourcesqueeze4.0.3-14+deb6u1mediumDLA-305-1
screensourcewheezy4.1.0~20120320gitdb59704-7+deb7u1mediumDSA-3352-1

Notes

https://savannah.gnu.org/bugs/?45713
http://www.openwall.com/lists/oss-security/2015/09/01/1

Search for package or bug name: Reporting problems