CVE-2015-6822

NameCVE-2015-6822
DescriptionThe destroy_buffers function in libavcodec/sanm.c in FFmpeg before 2.7.2 does not properly maintain height and width values in the video context, which allows remote attackers to cause a denial of service (segmentation violation and application crash) or possibly have unspecified other impact via crafted LucasArts Smush video data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch (security), stretch7:3.2.12-1~deb9u1fixed
buster, sid7:4.0.3-1fixed
libav (PTS)jessie (security), jessie6:11.12-1~deb8u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)7:2.7.2-1high
ffmpegsourcesqueeze(unfixed)end-of-life
libavsource(unstable)(unfixed)high

Notes

[squeeze] - ffmpeg <end-of-life> (Not supported in Squeeze LTS)
http://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=39bbdebb1ed8eb9c9b0cd6db85afde6ba89d86e4

Search for package or bug name: Reporting problems