CVE-2015-6831

NameCVE-2015-6831
DescriptionMultiple use-after-free vulnerabilities in SPL in PHP before 5.4.44, 5.5.x before 5.5.28, and 5.6.x before 5.6.12 allow remote attackers to execute arbitrary code via vectors involving (1) ArrayObject, (2) SplObjectStorage, and (3) SplDoublyLinkedList, which are mishandled during unserialization.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-341-1, DSA-3344-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy5.4.45-0+deb7u2fixed
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.6.12+dfsg-1high
php5sourcejessie5.6.12+dfsg-0+deb8u1highDSA-3344-1
php5sourcesqueeze5.3.3.1-7+squeeze28highDLA-341-1
php5sourcewheezy5.4.44-0+deb7u1highDSA-3344-1

Notes

https://bugs.php.net/bug.php?id=70169
https://bugs.php.net/bug.php?id=70168
https://bugs.php.net/bug.php?id=70166
https://bugs.php.net/bug.php?id=70155
http://www.openwall.com/lists/oss-security/2015/08/19/3
Fixed upstream in 5.4.44 and 5.6.12

Search for package or bug name: Reporting problems