CVE-2015-7182

NameCVE-2015-7182
DescriptionHeap-based buffer overflow in the ASN.1 decoder in Mozilla Network Security Services (NSS) before 3.19.2.1 and 3.20.x before 3.20.1, as used in Firefox before 42.0 and Firefox ESR 38.x before 38.4 and other products, allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via crafted OCTET STRING data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-354-1, DLA-480-1, DSA-3393-1, DSA-3410-1, DSA-3688-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)jessie1:52.3.0-4~deb8u2fixed
nss (PTS)jessie2:3.26-1+debu8u3fixed
jessie (security)2:3.26-1+debu8u9fixed
stretch (security), stretch2:3.26.2-1.1+deb9u1fixed
buster2:3.42.1-1+deb10u1fixed
buster (security)2:3.42.1-1+deb10u2fixed
bullseye2:3.45-1fixed
sid2:3.47.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icedovesource(unstable)38.4.0-1
icedovesourcejessie38.4.0-1~deb8u1DSA-3410-1
icedovesourcesqueeze(unfixed)end-of-life
icedovesourcewheezy38.4.0-1~deb7u1DSA-3410-1
iceweaselsource(unstable)38.4.0esr-1
iceweaselsourcejessie38.4.0esr-1~deb8u1DSA-3393-1
iceweaselsourcesqueeze(unfixed)end-of-life
iceweaselsourcewheezy38.4.0esr-1~deb7u1DSA-3393-1
nsssource(unstable)2:3.20.1-1
nsssourcejessie2:3.26-1+debu8u1DSA-3688-1
nsssourcesqueeze3.12.8-1+squeeze13DLA-354-1
nsssourcewheezy2:3.14.5-1+deb7u6DLA-480-1

Notes

http://hg.mozilla.org/projects/nss/rev/4dc247276e58
http://hg.mozilla.org/projects/nss/rev/534aca7a5bca
http://hg.mozilla.org/projects/nss/rev/b4feb2cb0ed6
https://www.mozilla.org/en-US/security/advisories/mfsa2015-133/
Patch for wheezy/jessie: https://lists.debian.org/debian-lts/2015/11/msg00098.html

Search for package or bug name: Reporting problems