CVE-2015-7183

NameCVE-2015-7183
DescriptionInteger overflow in the PL_ARENA_ALLOCATE implementation in Netscape Portable Runtime (NSPR) in Mozilla Network Security Services (NSS) before 3.19.2.1 and 3.20.x before 3.20.1, as used in Firefox before 42.0 and Firefox ESR 38.x before 38.4 and other products, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-344-1, DSA-3393-1, DSA-3406-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)wheezy38.7.0-1~deb7u1fixed
wheezy (security)1:52.3.0-4~deb7u2fixed
jessie1:45.8.0-3~deb8u1fixed
jessie (security)1:52.3.0-4~deb8u2fixed
stretch (security), stretch1:52.3.0-4~deb9u1fixed
sid1:52.3.0-4fixed
iceweasel (PTS)wheezy, wheezy (security)38.8.0esr-1~deb7u1fixed
jessie (security)38.8.0esr-1~deb8u1fixed
nspr (PTS)wheezy2:4.9.2-1+deb7u3fixed
wheezy (security)2:4.12-1+deb7u1fixed
jessie (security), jessie2:4.12-1+debu8u1fixed
stretch2:4.12-6fixed
buster, sid2:4.16-1fixed
virtualbox (PTS)jessie/contrib (security), jessie/contrib4.3.36-dfsg-1+deb8u1fixed
sid/contrib, buster/contrib5.2.0-dfsg-5fixed
wheezy, wheezy (security)4.1.42-dfsg-1+deb7u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icedovesource(unstable)31.7.0-1~deb8u1high
icedovesourcesqueeze(unfixed)end-of-life
iceweaselsource(unstable)38.4.0esr-1high
iceweaselsourcejessie38.4.0esr-1~deb8u1highDSA-3393-1
iceweaselsourcesqueeze(unfixed)end-of-life
iceweaselsourcewheezy38.4.0esr-1~deb7u1highDSA-3393-1
nsprsource(unstable)2:4.10.10-1high
nsprsourcejessie2:4.10.7-1+deb8u1highDSA-3406-1
nsprsourcesqueeze4.8.6-1+squeeze3highDLA-344-1
nsprsourcewheezy2:4.9.2-1+deb7u3highDSA-3406-1
virtualboxsource(unstable)5.0.10-dfsg-1high
virtualboxsourcejessie4.3.36-dfsg-1+deb8u1high
virtualbox-osesource(unstable)(unfixed)high
virtualbox-osesourcesqueeze(unfixed)end-of-life

Notes

[squeeze] - virtualbox-ose <end-of-life> (No longer supported in Squeeze LTS)
[wheezy] - virtualbox <no-dsa> (Minor issue, will be fixed when included in next CPU)
VirtualBox fixed: 4.0.36, 4.1.44, 4.2.36, 4.3.34, 5.0.10
http://hg.mozilla.org/projects/nspr/rev/c9c965b2b19c
http://hg.mozilla.org/projects/nspr/rev/bd8fb4498fa6
https://www.mozilla.org/en-US/security/advisories/mfsa2015-133/
Icedove, virtualbox(-ose)? have embedded copies of nspr.
Fixes impact macros PL_ARENA_ALLOCATE and PL_ARENA_GROW, other packages need to be recompiled:
jss (on wheezy/jessie) according to codesearch.debian.net

Search for package or bug name: Reporting problems