CVE-2015-7558

NameCVE-2015-7558
Descriptionlibrsvg before 2.40.12 allows context-dependent attackers to cause a denial of service (infinite loop, stack consumption, and application crash) via cyclic references in an SVG document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-477-1, DSA-3584-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
librsvg (PTS)wheezy2.36.1-2+deb7u1vulnerable
wheezy (security)2.36.1-2+deb7u2fixed
jessie (security), jessie2.40.5-1+deb8u2fixed
stretch2.40.16-1fixed
buster, sid2.40.18-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
librsvgsource(unstable)2.40.12-1medium
librsvgsourcejessie2.40.5-1+deb8u2mediumDSA-3584-1
librsvgsourcewheezy2.36.1-2+deb7u2mediumDLA-477-1

Notes

[squeeze] - librsvg <no-dsa> (Too intrusive to backport)
https://bugzilla.redhat.com/show_bug.cgi?id=1268243
https://git.gnome.org/browse/librsvg/commit/?id=a51919f7e1ca9c535390a746fbf6e28c8402dc61 (2.40.12)

Search for package or bug name: Reporting problems