CVE-2015-7744

NameCVE-2015-7744
DescriptionwolfSSL (formerly CyaSSL) before 3.6.8 does not properly handle faults associated with the Chinese Remainder Theorem (CRT) process when allowing ephemeral key exchange without low memory optimizations on a server, which makes it easier for remote attackers to obtain private RSA keys by capturing TLS handshakes, aka a Lenstra attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mariadb-10.0 (PTS)jessie10.0.32-0+deb8u1fixed
jessie (security)10.0.38-0+deb8u1fixed
mysql-5.5 (PTS)jessie5.5.60-0+deb8u1fixed
jessie (security)5.5.62-0+deb8u1fixed
wolfssl (PTS)sid4.1.0+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mariadb-10.0source(unstable)10.0.22-1low
mariadb-10.0sourcejessie10.0.22-0+deb8u1low
mysql-5.5source(unstable)5.5.46-0+deb8u1low
mysql-5.5sourcejessie5.5.46-0+deb8u1low
mysql-5.5sourcesqueeze5.5.46-0+deb6u1low
mysql-5.5sourcewheezy5.5.46-0+deb7u1low
mysql-5.6source(unstable)5.6.27-1low
wolfsslsource(unstable)3.9.10+dfsg-1low

Notes

http://www.oracle.com/technetwork/topics/security/cpujan2016-2367955.html#AppendixMSQL

Search for package or bug name: Reporting problems