CVE-2015-7941

NameCVE-2015-7941
Descriptionlibxml2 2.9.2 does not properly stop parsing invalid input, which allows context-dependent attackers to cause a denial of service (out-of-bounds read and libxml2 crash) via crafted XML data to the (1) xmlParseEntityDecl or (2) xmlParseConditionalSections function in parser.c, as demonstrated by non-terminated entities.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-266-1, DSA-3430-1
NVD severitymedium (attack range: remote)
Debian Bugs783010

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxml2 (PTS)wheezy2.8.0+dfsg1-7+wheezy5fixed
wheezy (security)2.8.0+dfsg1-7+wheezy11fixed
jessie (security), jessie2.9.1+dfsg1-5+deb8u5fixed
stretch (security), stretch2.9.4+dfsg1-2.2+deb9u1fixed
buster, sid2.9.4+dfsg1-5.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxml2source(unstable)2.9.2+really2.9.1+dfsg1-0.1medium783010
libxml2sourcejessie2.9.1+dfsg1-5+deb8u1mediumDSA-3430-1
libxml2sourcesqueeze2.7.8.dfsg-2+squeeze12mediumDLA-266-1
libxml2sourcewheezy2.8.0+dfsg1-7+wheezy5mediumDSA-3430-1

Notes

https://bugzilla.gnome.org/show_bug.cgi?id=744980
http://www.openwall.com/lists/oss-security/2015/04/19/5
http://www.openwall.com/lists/oss-security/2015/10/22/5
https://git.gnome.org/browse/libxml2/commit/?id=a7dfab7411cbf545f359dd3157e5df1eb0e7ce31 (v2.9.3)
https://git.gnome.org/browse/libxml2/commit/?id=9b8512337d14c8ddf662fcb98b0135f225a1c489 (v2.9.3)

Search for package or bug name: Reporting problems