CVE-2015-8011

NameCVE-2015-8011
DescriptionBuffer overflow in the lldp_decode function in daemon/protocols/lldp.c in lldpd before 0.8.0 allows remote attackers to cause a denial of service (daemon crash) and possibly execute arbitrary code via vectors involving large management addresses and TLV boundaries.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2571-1, DSA-4836-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lldpd (PTS)stretch0.9.6-1fixed
buster1.0.3-1fixed
bullseye, sid1.0.11-1fixed
openvswitch (PTS)stretch2.6.2~pre+git20161223-3vulnerable
stretch (security)2.6.10-0+deb9u1fixed
buster2.10.0+2018.08.28+git.8ca7c82b7d+ds1-12+deb10u2vulnerable
buster (security)2.10.7+ds1-0+deb10u1fixed
bullseye, sid2.15.0+ds1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lldpdsourcesqueeze(not affected)
lldpdsourcewheezy(not affected)
lldpdsourcejessie0.7.11-2+deb8u1
lldpdsource(unstable)0.7.19-1
openvswitchsourcestretch2.6.10-0+deb9u1DLA-2571-1
openvswitchsourcebuster2.10.6+ds1-0+deb10u1DSA-4836-1
openvswitchsource(unstable)2.15.0~git20210104.def6eb1ea+dfsg1-1

Notes

[wheezy] - lldpd <not-affected> (Vulnerable code not present)
[squeeze] - lldpd <not-affected> (Vulnerable code not present)
https://github.com/lldpd/lldpd/commit/dd4f16e7e816f2165fba76e3d162cd8d2978dcb2
https://www.openwall.com/lists/oss-security/2015/10/16/2
https://mail.openvswitch.org/pipermail/ovs-announce/2021-January/000268.html
https://mail.openvswitch.org/pipermail/ovs-dev/2020-November/377394.html
https://github.com/openvswitch/ovs/commit/bb5a9937fa8e04e71052fb50e23894448d19678f

Search for package or bug name: Reporting problems