CVE-2015-8012

NameCVE-2015-8012
Descriptionlldpd before 0.8.0 allows remote attackers to cause a denial of service (assertion failure and daemon crash) via a malformed packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lldpd (PTS)buster1.0.3-1fixed
bullseye1.0.11-1+deb11u1fixed
bookworm, sid1.0.14-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lldpdsourcesqueeze(not affected)
lldpdsourcewheezy(not affected)
lldpdsourcejessie0.7.11-2+deb8u1
lldpdsource(unstable)0.7.19-1

Notes

[wheezy] - lldpd <not-affected> (Vulnerable code not present)
[squeeze] - lldpd <not-affected> (Vulnerable code not present)
https://github.com/lldpd/lldpd/commit/793526f8884455f43daecd0a2c46772388417a00
https://www.openwall.com/lists/oss-security/2015/10/18/2

Search for package or bug name: Reporting problems