CVE-2015-8036

NameCVE-2015-8036
DescriptionHeap-based buffer overflow in ARM mbed TLS (formerly PolarSSL) 1.3.x before 1.3.14 and 2.x before 2.1.2 allows remote SSL servers to cause a denial of service (client crash) and possibly execute arbitrary code via a long session ticket name to the session ticket extension, which is not properly handled when creating a ClientHello message to resume a session. NOTE: this identifier was SPLIT from CVE-2015-5291 per ADT3 due to different affected version ranges.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3468-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mbedtls (PTS)stretch (security), stretch2.4.2-1+deb9u1fixed
buster, sid2.6.0-1fixed
polarssl (PTS)wheezy, wheezy (security)1.2.9-1~deb7u6fixed
jessie1.3.9-2.1+deb8u2fixed
jessie (security)1.3.9-2.1+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mbedtlssource(unstable)(not affected)
polarsslsource(unstable)(unfixed)medium
polarsslsourceexperimental1.3.14-0.1medium
polarsslsourcejessie1.3.9-2.1+deb8u1mediumDSA-3468-1
polarsslsourcesqueeze(not affected)
polarsslsourcewheezy1.2.9-1~deb7u6mediumDSA-3468-1

Notes

- mbedtls <not-affected> (Fixed before the initial release to Debian)
[wheezy] - polarssl <not-affected> (Vulnerable code introduced later)
[squeeze] - polarssl <not-affected> (Vulnerable code introduced later)
support for session tickets added in 1.3.0.
https://tls.mbed.org/tech-updates/security-advisories/mbedtls-security-advisory-2015-01

Search for package or bug name: Reporting problems