CVE-2015-8041

NameCVE-2015-8041
DescriptionMultiple integer overflows in the NDEF record parser in hostapd before 2.5 and wpa_supplicant before 2.5 allow remote attackers to cause a denial of service (process crash or infinite loop) via a large payload length field value in an (1) WPS or (2) P2P NFC NDEF record, which triggers an out-of-bounds read.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3397-1
NVD severitymedium (attack range: remote)
Debian Bugs795740

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wpa (PTS)wheezy1.0-3+deb7u3fixed
wheezy (security)1.0-3+deb7u4fixed
jessie2.3-1+deb8u4fixed
jessie (security)2.3-1+deb8u5fixed
stretch2:2.4-1fixed
stretch (security)2:2.4-1+deb9u1fixed
buster, sid2:2.4-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hostapdsource(unstable)(unfixed)medium
hostapdsourcesqueeze(not affected)
wpasource(unstable)2.3-2.2medium795740
wpasourcejessie2.3-1+deb8u3mediumDSA-3397-1
wpasourcewheezy1.0-3+deb7u3mediumDSA-3397-1
wpasupplicantsource(unstable)(unfixed)medium
wpasupplicantsourcesqueeze(not affected)

Notes

[squeeze] - wpasupplicant <not-affected> (0.7.0-v2.4 with with CONFIG_WPS_NFC=y)
[squeeze] - hostapd <not-affected> (v0.7.0-v2.4 with CONFIG_WPS_NFC=y)
http://www.openwall.com/lists/oss-security/2015/07/08/3
http://w1.fi/security/2015-5/

Search for package or bug name: Reporting problems