CVE-2015-8217

NameCVE-2015-8217
DescriptionThe ff_hevc_parse_sps function in libavcodec/hevc_ps.c in FFmpeg before 2.8.2 does not validate the Chroma Format Indicator, which allows remote attackers to cause a denial of service (out-of-bounds array access) or possibly have unspecified other impact via crafted High Efficiency Video Coding (HEVC) data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch (security), stretch7:3.2.12-1~deb9u1fixed
buster, sid7:4.0.3-1fixed
libav (PTS)jessie (security), jessie6:11.12-1~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)7:2.8.2-1high
ffmpegsourcesqueeze(not affected)
libavsource(unstable)undeterminedhigh
libavsourcejessie(not affected)
libavsourcewheezy(not affected)

Notes

[squeeze] - ffmpeg <not-affected> (Vulnerable code not present)
[jessie] - libav <not-affected> (Contains a similar code block like the one referenced by the ffmpeg commit)
[wheezy] - libav <not-affected> (Vulnerable code not present)
https://git.videolan.org/?p=ffmpeg.git;a=commit;h=93f30f825c08477fe8f76be00539e96014cc83c8

Search for package or bug name: Reporting problems