CVE-2015-8476

NameCVE-2015-8476
DescriptionMultiple CRLF injection vulnerabilities in PHPMailer before 5.2.14 allow attackers to inject arbitrary SMTP commands via CRLF sequences in an (1) email address to the validateAddress function in class.phpmailer.php or (2) SMTP command to the sendCommand function in class.smtp.php, a different vulnerability than CVE-2012-0796.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-363-1, DSA-3416-1
NVD severitymedium (attack range: remote)
Debian Bugs807265

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libphp-phpmailer (PTS)wheezy5.1-1.1fixed
wheezy (security)5.1-1.3+deb7u1fixed
jessie (security), jessie5.2.9+dfsg-2+deb8u3fixed
buster, sid, stretch5.2.14+dfsg-2.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libphp-phpmailersource(unstable)5.2.14+dfsg-1medium807265
libphp-phpmailersourcejessie5.2.9+dfsg-2+deb8u1mediumDSA-3416-1
libphp-phpmailersourcesqueeze5.1-1+deb6u11mediumDLA-363-1
libphp-phpmailersourcewheezy5.1-1.1mediumDSA-3416-1

Notes

https://github.com/PHPMailer/PHPMailer/commit/6687a96a18b8f12148881e4ddde795ae477284b0 (v5.2.14)

Search for package or bug name: Reporting problems