CVE-2015-8614

NameCVE-2015-8614
DescriptionMultiple stack-based buffer overflows in the (1) conv_jistoeuc, (2) conv_euctojis, and (3) conv_sjistoeuc functions in codeconv.c in Claws Mail before 3.13.1 allow remote attackers to have unspecified impact via a crafted email, involving Japanese character set conversion.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-383-1, DSA-3452-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
claws-mail (PTS)wheezy, wheezy (security)3.8.1-2+deb7u1fixed
jessie (security), jessie3.11.1-3+deb8u1fixed
stretch3.14.1-3fixed
buster, sid3.15.1-1fixed
macopix (PTS)wheezy1.7.4-4vulnerable
jessie1.7.4-5vulnerable
buster, stretch, sid1.7.4-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
claws-mailsource(unstable)3.13.1-1high
claws-mailsourcejessie3.11.1-3+deb8u1highDSA-3452-1
claws-mailsourcesqueeze3.7.6-4+squeeze2highDLA-383-1
claws-mailsourcewheezy3.8.1-2+deb7u1highDSA-3452-1
macopixsource(unstable)1.7.4-6high

Notes

[jessie] - macopix <no-dsa> (Minor issue)
[wheezy] - macopix <no-dsa> (Minor issue)
http://git.claws-mail.org/?p=claws.git;a=commit;h=d390fa07f5548f3173dd9cc13b233db5ce934c82 (3.13.1)
http://git.claws-mail.org/?p=claws.git;a=commitdiff;h=e3ffcb455e0376053451ce968e6c71ef37708222 (not yet in tagged release)
Upstream patch is broken - first comparison uses wrong operator and others appear
to assume wrong maximum character length.
http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=3557
http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=3584
https://bugs.gentoo.org/show_bug.cgi?id=569010

Search for package or bug name: Reporting problems