CVE-2015-8663

NameCVE-2015-8663
DescriptionThe ff_get_buffer function in libavcodec/utils.c in FFmpeg before 2.8.4 preserves width and height values after a failure, which allows remote attackers to cause a denial of service (out-of-bounds array access) or possibly have unspecified other impact via a crafted .mov file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch (security), stretch7:3.2.12-1~deb9u1fixed
buster, sid7:4.0.3-1fixed
libav (PTS)jessie (security), jessie6:11.12-1~deb8u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)7:2.8.4-1high
ffmpegsourcesqueeze(unfixed)end-of-life
libavsource(unstable)(unfixed)high

Notes

[squeeze] - ffmpeg <end-of-life> (Not supported in Squeeze LTS)
http://git.videolan.org/?p=ffmpeg.git;a=commit;h=abee0a1c60612e8638640a8a3738fffb65e16dbf
For libav in jessie the patch needs to applied in libavcodec/decode.c in line 1884.

Search for package or bug name: Reporting problems