CVE-2015-8857

NameCVE-2015-8857
DescriptionThe uglify-js package before 2.4.24 for Node.js does not properly account for non-boolean values when rewriting boolean expressions, which might allow attackers to bypass security mechanisms or possibly have unspecified other impact by leveraging improperly rewritten Javascript.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
uglifyjs (PTS)jessie2.4.15-1vulnerable
stretch2.7.5-2vulnerable
buster, sid2.8.29-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
uglifyjssource(unstable)(unfixed)unimportant

Notes

fixed in 2.4.24
https://zyan.scripts.mit.edu/blog/backdooring-js/
https://github.com/mishoo/UglifyJS2/issues/751
https://nodesecurity.io/advisories/39
nodejs not covered by security support

Search for package or bug name: Reporting problems