CVE-2015-8858

NameCVE-2015-8858
DescriptionThe uglify-js package before 2.6.0 for Node.js allows attackers to cause a denial of service (CPU consumption) via crafted input in a parse call, aka a "regular expression denial of service (ReDoS)."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
uglifyjs (PTS)jessie2.4.15-1vulnerable
stretch2.7.5-2vulnerable
buster, sid2.8.29-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
uglifyjssource(unstable)(unfixed)unimportant

Notes

libv8 is not covered by security support
https://nodesecurity.io/advisories/48

Search for package or bug name: Reporting problems