CVE-2015-8972

NameCVE-2015-8972
DescriptionStack-based buffer overflow in the ValidateMove function in frontend/move.cc in GNU Chess (aka gnuchess) before 6.2.4 might allow context-dependent attackers to execute arbitrary code via a large input, as demonstrated when in UCI mode.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnuchess (PTS)wheezy6.0.2-1vulnerable
jessie6.1.2-1vulnerable
stretch6.2.4-1fixed
buster, sid6.2.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnuchesssource(unstable)6.2.4-1unimportant

Notes

Built with hardening flags, no security impact
http://lists.gnu.org/archive/html/bug-gnu-chess/2015-10/msg00002.html
http://svn.savannah.gnu.org/viewvc?view=rev&root=chess&revision=134

Search for package or bug name: Reporting problems